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INTRODUCTION 
Time-lapse zymography (TLZ) is an in situ quantitative method developed for evaluating 

and mapping the activity of hydrolytic enzymes on soil/root surfaces. It uses time-lapse 

photography to measure dynamics of fluorescence development in the membrane saturated in 

enzymes specific substrate mixed with fluorogenic reagents and incubated on soil/root surface. 

TLZ calculates the enzyme activity in each pixel of the membrane based on the highest rate of 

signal development with correction for losses due to product diffusion in the soil and membrane. 

The details of TLZ approach and calibration procedure are described in Guber et al. (2019, 

2021). The developed code is an open source and can be obtained upon request from 

akguber@msu.edu. Although the code has been tested by its developers, no warranty, expressed 

or implied, is made as to the accuracy and functioning of the program modifications and related 

program material, nor shall the fact of distribution constitute any such warranty, and no 

responsibility is assumed by the developers in connection therewith. 

How to cite the TLZ procedure and code: 

1. Guber, A.K., Kravchenko, A.N., Razavi, B.S., Blagodatskaya, E., Kuzyakov, Y. 2019. 

Calibration of 2-D soil zymography for correct analysis of enzyme distribution. European 

Journal of Soil Science 70(4): 715-726. 

2. Guber, A.K., Blagodatskaya, E., Juyal, A., Razavi, B.S., Kuzyakov, Y. Kravchenko, 

A.N., 2021. Time-lapse approach to correct deficiencies of 2D soil zymography. Soil Biology 

and Biochemistry 157: 108225.   
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I. Experimental setup for TLZ 
Parts and software for TLZ include (Fig.1): 

1. A DSLR camera compatible with Helicon remote software (Canon EOS Rebel T6 or newer 

models). 

2. Telephoto Zoom Lens (Canon EF 75-300 mm f/4-5.6 III Telephoto Zoom Lens) 

3. Fotodiox Macro Extension Tube Set for Canon EOS (EF, EF-S) Mount DSLR Cameras 

4. Photocopy stand (50-70 cm height to accommodate focus distance of the telephoto lens)  

5. Dimmer with LED Halo Headlight Accent Lights - UV-BlackLight + Natural White 

6. Frame for rhizobox zymography 

7. Helicon remote software (https://www.heliconsoft.com/heliconsoft-products/helicon-

remote/) 

8. TKDY ACK-E10 AC Power Adapter for Canon EOS Rebel T6 camera. 

9. Hydrophilic polyamide membrane filter (HPMF) of 100 µm thickness with average pore size 

of 0.45 µm (Tao Yuan, China or Sigma Aldrich). 

 

Assembling and operation 

1. Connect all parts as shown in Fig. 2. 

2. Install and start the Helicon remote software. 

3. Switch camera to manual focus and shooting mode (M). 

4. Turn the natural white lights on. 

5. Place a scale grid paper or fine font print-out on the base of photocopy stand (or zymography 

box) and adjust the camera height and focus manually. The size of the paper sheet should be 

approximately 20% larger, than the rhizobox. Change the extension tube if the grid or letters 

are out of focus distance of the camera. Focus should be adjusted manually using the camera 

focusing ring and kept unchanged during TLZ.  

6.  Switch light source to the UV-Black Light. 

7. Place a clean HPMF on the base of photocopy stand and take photo. 

8. In ImageJ check the uniformity of the brightness across the image. 

  

https://www.heliconsoft.com/heliconsoft-products/helicon-remote/
https://www.heliconsoft.com/heliconsoft-products/helicon-remote/
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Figure 1. TLZ parts 
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Figure 2. TLZ setup 

 

9. Adjust height of the light source to achieve the most uniform light distribution. 

10. Run the calibration procedure with different light (dimmer) and camera settings (exposure 

time) as described in Guber et al. (2019) to achieve the best signal to noise ratio in possibly 

(1) 

(2) 

(3) 

(5) 

(4) 
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broader range of MUF values with linear relationship between greyscale values and MUF 

mass in the HPMF.  

 

Default Camera and Helicon remote software settings for TLZ 

1. Focus:   Manual 

2. Aperture:   f/5.6 

3. Exposure time:  1/125 sec 

4. ISO speed rating:  800 

5. Time lapse Interval: 60 sec 

6. Number of shots: 40 

 

 

 

II. TLZ procedure 

Sequence of TLZ operations is shown in Fig. 3.                  
   

II-1. Image calibration on standard MUF solutions 

* TLZ uses UV light source and should be done in a dark room/hood. 

1. Prepare 5-6 standard MUF solutions at concentrations within the range of linear increase in 

fluorescent intensity (e.g., 0.1, 0.25, 0.5, 1.0, and 2.0 mM). 

2. Using pipette, apply 5 -10 µl of each concentration solution to HPMF in 2-3 replications. 

3. Cover the membranes immediately after MUF application with a transparent film to prevent 

evaporation and take 3-5 photos every 5 minutes using the settings desired for TLZ. 

4. Open the calibration sequence in ImageJ and convert to 8-bit (Image -> Type -> 8-bit). 

Alternatively, one of the RGB channel can be used (Image -> Color -> Split Channels). 

5. Run G_time.ijm to check stability of the signal in time for different ROIs in the calibration 

image. Select images for MUF calibration within stable range of the signal. 

6. Process the calibration images using Calibration_Linear.ijm macro in ImageJ software 

following pop-up instructions: 

a. Enter MUF mass for each calibration spot in line 10 of this macro. 

Image calibration on standard 
MUF solutions

Time-lapse photography of 
rhizobox with membrane 

saturated in substrate

Processing TLZ images

Enzymatic activity calculations 

Processing enzyme activity 
image

Figure 3. TLZ flowchart 
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b. Run Calibration_Linear.ijm macro  

c. Select the directory with the calibration images (e.g. Calibration). 

d. Open the calibration image from this directory (e.g. File -> Open -> MUF.JPG) 

e. Select ROI around all MUF spots using Rectangle selection tool and click OK. 

f. Select channel (All – Default, R – for Oxyred). 

g. Select the background on one of the membranes using Rectangle selection tool and click 

OK. 

h. Threshold the Mask to identify the MUF spots (Image -> Adjust -> Threshold -> 

Apply). Click OK in the pop-up window. 

i. Enter the number of calibration spots in the image. 

 

Figure 4. An example of MUF calibration regression. X denotes Sum(G*F), Y denotes MUF 

mass [nmol] in each calibration spot. The regression is close to linear for MUF mass 0 < Y < 10 

nmol. The slope of calibration line a  = 4.338 10-4 pmol MUF pix-1 greyscale-1(see insert). 
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j. Starting from the first spot, select one by one all spots using Rectangle selection tool 

and clicking OK after each selection. The spots must be selected in the order of MUF 

mass entered in line 10 of this macro. 

k. Check the linearity of the calibration on the calibration plot. Save the parameter a for 

TLZ calculations (parameter b1 in Table 1). The units for a are [MUF mass units/grey 

value/pixel]. 

l. The macro saves MUF mass and Sum(G*F) for each calibration spot to file Totgrey.txt, 

which can be used for manual calibration in Excel or any other software.   

7. Use the calibration parameter a in the enzymatic activity calculations described below. 

* The calibration code can be used only for linear relationship between the greyscale values 

G and mass of the standard solution. For non-linear calibration, use a piecewise linear 

regression (Guber et al., 2019). 

 

II-2. Time-lapse photography of rhizobox with membrane saturated in substrate. 

* wear gloves and use autoclaved laboratory glassware when working with enzymes.  

1. Cut HPMF of size needed for TLZ. 

2. Prepare working solution of the substrate for specific enzymes. 

3. Place a rhizobox on the base of the photo-table. 

4. Start Helicon remote software and adjust focus manually in natural white light. 

5. Set exposure time, ISO, time lapse interval and number of shots in Helicon remote 

software. The exposure time, ISO and focus distance must be the same as for the 

calibration. 

6. Switch the light source to UV. 

7. Saturate HPMF in the substrate solution. 

8. Spray soil/root surface in the rhizobox with DI water to assure hydraulic connectivity of 

membrane with the soil surface. 

9. Fix saturated HPMF with a clean transparent film above it in the frame for rhizobox 

zymography (Fig.1 (6)) and immediately place on the soil surface. Fix the frame in the 

rhizobox using 4 springs.  
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10. Start time lapse shooting. Time interval between the start of TLZ and membrane removal 

from the substrate must be as short as possible, because the first image is used for the 

background removal in the image processing procedure. 

 

Figure 4. Soil rhizobox with young corn roots (left), and zymography image taken at 40th 

minute of phosphatase zymography (right).  

  

 III. Processing TLZ image sequences. 

III-1. The first step of data processing is converting the TLZ images (RGB) to 8-bit format, 

removing the noise and background. To do that, run TLZ-process.ijm macro in ImageJ 

software and follow the pop-up instructions:  

1. Select directory with TLZ image sequence. All images will be open automatically. Check 

that the directory contains only zymography images taken during single TLZ session.  

2. Select ROI using a rectangle or oval tool to crop TLZ images for reduction of the area to be 

processed. 

3. Select channel (All - Default, R - for Oxyred). 

4. The macro converts RGB images into 8-bit format (without rescaling), subtracts the first TLZ 

image from the whole stack, and removes the image noise using a 3D median filter (radius = 

3 pixels). The user can change the filter and its settings in line 65 of the macro. Filtering may 



10 
 

take several minutes. Please wait until message “Save processed images to MUF directory" 

pops-up.  

5. Save MUF_filt sequence in TIFF format to new directory for activity calculations (e.g. 

MUF_filt: File -> Save as -> Image Sequence -> MUF_filt). 

6. You may view the Greyscale time dynamics in different regions of the zymogram using 

G_time.ijm macro.   

 

III-2. The third step of data processing is processing the enzyme activity image in individual 

pixels based on the linear parts of the Greyscale time dynamics and the correction factor for 

MUF diffusion losses. MATLAB code “Activity_time.m” uses the sequences of images 

obtained in III-1 with the parameters specified in ASCII file Par.dat and time moments, 

when the images were taken, specified in ASCII file Time.dat. Input files Time.dat and 

Par.dat must be in the same directory with MUF_filt00XX.tif files.  

Table 1.  Format of Par.dat file: 

Line Parameter value Comment 

1 b1 3.31E-04 MUF calibration parameters (Guber et al., 2019): 

�
𝑀𝑀𝑀𝑀𝑀𝑀𝑀𝑀 = 𝑏𝑏1 ⋅ 𝐺𝐺;              0 < 𝐺𝐺 < 𝐺𝐺 ∗
𝑀𝑀𝑀𝑀𝑀𝑀𝑀𝑀 = 𝑎𝑎2 + 𝑏𝑏2 ⋅ 𝐺𝐺;              𝐺𝐺 ∗< 𝐺𝐺
𝑏𝑏2 = 𝑏𝑏1 − 𝑎𝑎2/𝐺𝐺 ∗

 
2 a2 -0.19501 

3 b2 2.547E-03 

4 G* 88 

5 Npoints > 2 Number of datapoints to calculate the derivative dMUF/dTime 

6 R2min 0.8 Min acceptable R2 for the derivative calculation. 

7 Resol, um 17 Pixel size in TLZ image 

8 TimeStep, 
min 

1 Time interval used in TLZ. If TimeStep=0, enter time moments 
for TLZ in file Time.dat 

9* Gmin 1 Min greyscale value in the pixel to run the activity calculations.  
Activity = 0 for G < Gmin 

10* SlopeMin 0.1 Min slope of G_time in MUF_filt00XX.tif to run the activity 
calculations.  Activity = 0 for dG/dTime < Gmin 

11* SigmaGmin 1.0 Min standard deviation in G_time  to run the activity 
calculations.  Activity = 0 for StDev(G_time) < SigmaGmin  



11 
 

* Use the parameters Gmin, SlopeMin, and SigmaGmin to remove image pixels with high oscillations of 

G-values, or insignificant changes of brightness on images during TLZ (noise) and to reduce the 

computational time. To estimate the parameter values, run G_time.ijm macro for different regions of 

MUF_filt00XX.tif sequence. 

Time.dat is required only for irregular time intervals during TLZ (TimeStep=0). Time moments 

entered in an increasing order separated by Space.    

1. Enter the Directory containing the MUF_filt00XX.tif sequence in Line 24 of the Matlab 

code Activity_time.m. Check for presence of Par.dat and Time.dat (if required) files in 

this directory. 

2. Check the parameter values in Par.dat and time data in Time.dat  files. 

3. Run Activity_time.m. 

4. The code generates three plots: Time series of Number of active pixels (Fig. 1), 

calculated Average ± 1σ activities (Fig. 2), and Average activities after correction for 

MUF losses (Fig. 3). The time denotes time moments, when the derivatives dMUF/dTime 

were calculated at R2 > R2min in image pixels. These plots are for information purpose 

only, to provide an idea about the time when the highest activity was detected, number of 

active pixels, and distributions of corrected activities over time of peak activities.  

Figure 5. Examples of Text Image files: Activity.res (left), Fraction.res (center) and 

Time_der.res (right). 

5. Results of the activity calculations saved to four Text Image files:  

• Activity.res – enzyme activities in pixels without correction for MUF losses. 

• Fraction.res – the activity correction factor for each pixel. 
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• Time_der.res – maximum values of derivative dMUF/dTime in image pixels. 

• Time_der.res – the time moments when the derivatives were the highest in image 

pixels. 

 

III-3. The third step of TLZ processing is calculating the enzyme activity using the results of 

Activity_time.m procedure. Specifically, text image file Activity.res is multiplied by Fraction.res 

to generate the activity image Act_cor-BW.tif corrected for MUF losses. The user has an option 

to remove pixels with late detection time (less reliable activity calculations). 

1. Run Activity_process.ijm 

2. Threshold “Mask” image, which is a 2D map of time moments when the activities in the 

pixels were the highest. Image -> Adjust -> Threshold. Select the lower thresholds tmin >1 

min and upper thresholds tmax based on time when you believe the appearance of new active 

pixels was mostly associated with MUF diffusion within the membrane (Guber et al., 2021).  

There is no rule of thumb for choosing the upper threshold. For β-glucosidase TLZ in ~ 200 

soil samples tmax occurred more frequently within the range 28-32 min. Click OK in “Run 

Threshold for MASK” pop-up window. 

3. The macro creates an 8-bit image with corrected activities and RGB image with a color scale 

for presentation. The lookup table and parameters of the scale window can be changed in 

lines 56-57 of the macro. The name of 8-bit activity image is SourceDirName-BW.tif and 

RGB activity image - SourceDirName-RGB.ipg.  

4. The 8-bit activity image SourceDirName-BW.tif is intended to be used for further analysis of 

spatial distribution, while the RBG image for presentation. 

5. Close all active windows before processing next TLZ sequence: File -> Close All. 
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Figure 6. Results of phosphatase activity calculations in 32-bit format (left) and RGB (right). The 
activity units are pmol mm-2 min-1 

 

III-4. Description of the G_time.ijm macro  

G_time.ijm macro plots time series of G-values in the center of selected region in TLZ 

sequence. 

1. Open a TLZ sequence. 

2. Open G_time.ijm macro. 

3. For irregular time intervals enter time moments when the photos were taken in line 14 and 

comment line 20 in the macro. 

4. For regular 1-minute time interval no changes in macro are needed. 

5. Select a ROI using either a rectangle or oval tool. 

6. Run the macro. 

7. The StDev of G-values is printed in “Log” window. 

8. The time series of G-values is plotted in “Plot G” window. 

9. In the “Plot G” window click Data -> Add Fit to get the parameters of linear regression. 

10. Parameter b of the linear regression and maximum G-value can be used to estimate the 

parameters SlopeMin and Gmin for Matlab procedure Activity_time.m, when a region with 
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the lowest activity is selected. StDev of G-value printed in “Log” window can be used to 

estimate the parameter SigmaGmin for the same procedure. 

Figure 7. An example of G-values time series plot. G-values increased linearly within time 

interval 13-22 minutes.    

 

Examples 

Examples of calibration and TLZ data processing are provided in directories “Calibration” 

and “TLZ” for β-Glucosidase and acid-Phosphatase. 

IV-1. Calibration on standard MUF solutions for b-Glucosidase and Phosphatase TLZ. 

For calibration, 5 µl of 0.1, 0.25, 0.5, 1.0, and 2.0 mM MUF solutions were applied to the 

membrane (Fig. 4 top) and photographed (…\TLZ\Calibration\MUF.jpg). The image was 

processed using Calibration_Linear.ijm macro. Results: Sum(G*F) for each MUF mass are 

saved in file “Totgrey.txt” and plotted (Fig. 4 bottom). The calibration regression was close to 

linear with the slope a  = 4.338 10-4 pmol MUF pix-1 greyscale-1.  

IV-2. TLZ for β-Glucosidase 
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Directory “…\TLZ\beta-glucosidase\RAW” contains sequence of images taken at 1-minute 

interval during 45-minute β-Glucosidase TLZ on the surface a cylindrical soil core. This 

sequence was processed using macro TLZ-process.ijm and resulting MUF_filtXXXX.tif files 

were saved to “…\TLZ\beta-glucosidase\MUF_filt” directory in 8-bit format along with the 

selected region “…\TLZ\beta-glucosidase\RAW\Selection.roi”. The last file can be used for 

alignment of calculated enzyme activity with a soil surface image if was taken.  

 The parameter file “…\TLZ\beta-glucosidase\MUF_filt\Par.dat” was created in an ASCI 

editor as input for Activity_time.m MATLAB procedure. The calibration parameter b1 was 

estimated in section IV-1. Parameters a2 and b2 are used for piecewise calibration function that 

includes oversaturating MUF values (Table 1) and will be ignored in this example by setting G* 

to a much larger value, than was obtained in MUF_filtXXXX.tif files. Since 45-minute TLZ 

generated 45 datapoints in each zymography pixel, we choose 10-minute time sliding window 

for the derivative dMUF/dT calculations (Npoints 10). Larger window removes oscillations from 

MUF time series. However, too large windows potentially reduce dMUF/dT values. Proper value 

of the Npoints can be obtained from linear parts of G-values time series using G_time.ijm macro 

(Fig. 7). Parameter “TimeStep” was set equal to 1 minute, which was the TLZ time interval. File 

“Time.dat” was not required in the activity calculations since the time interval did not change 

during TLZ. Parameters “Gmin”, “SlopeMin” and “SigmaGmin” were estimated from G-values 

time series to remove pixels with low and/or not reliable G-values and reduce the processing 

time. 

Running Activity_time.m MATLAB procedure, with the path to MUF_filtXXXX.tif files 

(“…\TLZ\beta-glucosidase\MUF_filt”) specified in line 24 of  Activity_time.m and parameter 

values specified in “Par.dat” file, generates and saves “Activity.res”, “Fraction.res”, “R2.res” 

and “Time_der.res” text image files.  Three plots with statistics of the activity and number of 

active pixels will be saved along with the text image files to “…\TLZ\beta-

glucosidase\MUF_filt” directory. There are: Fig-1.jpg, Fig-2.jpg and Fig-3.jpg. 

Finally, running Activity_process.ijm with the results of Activity_time.m, one generates “beta-

glucosidase-BW.tif” and “beta-glucosidase-RGB.jpg” files with corrected activities in 32-bit and 

RGB formats, respectively. The first file is aimed to be used for further statistical analysis of 

activity distribution and/or association with soil, roots or pores, depending on the goal of soil 

zymography. The second file can be used for presentations. 
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IV-3. TLZ for acid Phosphatase 

Directory “…\TLZ\ Phosphatase\RAW” contains sequence of images taken at 5-minute 

interval during a 45-minute acid Phosphatase TLZ on the surface rhizobox. This sequence was 

processed using macro TLZ-process.ijm and resulting MUF_filtXXXX.tif files were saved to 

“…\TLZ\Phosphatase\MUF_filt” directory in 8-bit format along with the selected region 

“…\TLZ\Phosphatase\RAW\Selection.roi”. The last file can be used for alignment of calculated 

enzyme activity image with photo of soil surface if it was taken.  

 The parameter file “…\TLZ\Phosphatase\MUF_filt\Par.dat” was created in an ASCI editor as 

input for Activity_time.m MATLAB procedure. The calibration parameter b1 was estimated in 

section IV-1. Parameters a2 and b2 are used for piecewise calibration function that includes 

oversaturating MUF values (Table 1) and will be ignored in this example by setting G* to a 

much larger value, than was obtained in MUF_filtXXXX.tif files. Since 45-minute TLZ 

generated 9 datapoints in each zymography pixel, we choose 25-minute time sliding window for 

the derivative dMUF/dT calculations (Npoints 5). Parameter “TimeStep” was set equal to 5 

minutes, which was the TLZ time interval. File “Time.dat” was not required in the activity 

calculations since the time interval did not change during TLZ. Parameters “Gmin”, “SlopeMin” 

and “SigmaGmin” were estimated from G-values time series to remove pixels with low and/or 

not reliable G-values and reduce the processing time. 

Running Activity_time.m MATLAB procedure, with the path to MUF_filtXXXX.tif files 

(“…\TLZ\Phosphatase\MUF_filt”) specified in line 24 of  Activity_time.m and parameter values 

specified in “Par.dat” file, generates and saves “Activity.res”, “Fraction.res”, “R2.res” and 

“Time_der.res” text image files.  Three plots with statistics of the activity and number of active 

pixels will be saved along with the text image files to “…\TLZ\Phosphatase\MUF_filt” 

directory. There are: Fig-1.jpg, Fig-2.jpg and Fig-3.jpg. 

Finally, running Activity_process.ijm with the results of Activity_time.m, we generated 

“Phosphatase-BW.tif” and “Phosphatase-RGB.jpg” files with corrected activities in 32-bit and 

RGB formats, respectively.  

 

  


